Getting Started with the MapleSim
Connector for LabVIEW and NI VeriStand
Software

Copyright © Maplesoft, a division of Waterloo Maple Inc.
2011



Getting Started with the MapleSim Connector for LabVIEW and NI
VeriStand Software

Copyright
Maplesoft, Maple, and MapleSim are all trademarks of Waterloo Maple Inc.

© Maplesoft, a division of Waterloo Maple Inc. 2010-2011. All rights reserved.

No part of this book may be reproduced, stored in a retrieval system, or transcribed, in any form or by any means — electronic, mechanical, photo-
copying, recording, or otherwise. Information in this document is subject to change without notice and does not represent a commitment on the part
of the vendor. The software described in this document is furnished under a license agreement and may be used or copied only in accordance with
the agreement. It is against the law to copy the software on any medium except as specifically allowed in the agreement.

National Instruments, LabVIEW, and NI VeriStand are registered trademarks or registered trademarks of National Instruments.
Microsoft and Visual Studio are registered trademarks of Microsoft Corporation.

All other trademarks are the property of their respective owners.

This document was produced using a special version of Maple and DocBook.

Printed in Canada



Contents

a0 T4 (D 1o T ) R PSPPSR iv
L€ T8V P -V 1<« PPN 1
B (ST = (=] PP 1
1.2 Using the LabVIEW Component Block Generation Template .............cccveiviiiiiiiiiiiieiineiieeieeieeieeeane, 1
SUDSYSTEM PIEPATAtION ......iveiiniii ettt et et et et e et e e e et e et e et e e e aae e st e eaa e et e et e et esneeeneraneeanees 1
SUDSYSIEM SCIECIION .....iitiiteii et et et et et e et e et e et e et e et e et et e et e e b e eaa e et e et e et eaaeeaneeaneenneees 1

Port and Parameter ManagemEnt .............cvueiieeiineiieiieeieeei et et et et et erte et e et eeaeeneeanaesneraneenesenaes 2

EMI COmMPONENE OPLIONS .uvvniitiieiiteeiieiietieetie et ettt et e et e et et e ean e et e et e et e st eanaesnetaneeseenernaasnaarnes 2
Generate EMI Component COAe ........ovuiiiniiiniiieieeieiie et e e e e et e e e e e e e ate e s e eaaeeaeeaneeneaes 3

SIT COMPONENTE OPLIONS ..euuiiuiieiitetieit et et eet et e et et eate et et eata et etaetneanetsneeaesaeseaeseersneerneennns 4
Generate SIT Component COC .........iiuiiiiiiiiie e ettt et e et e et e e e et e et e et e s eaneeaneeaneees 5

View EMI or SIT Component COUE ........cuuuiiniiiniiieiie et ie e et et et e et e et e et e et e et eaeaeaaearneeaneennaees 5

1.3 Using the LabVIEW Block Generation TemPIates .............oviuiiiiiiiniiieiieiiee e e eieeieei e e e e e eaens 6
VIEWING EXAMPIES ...ivniiiiiiiii ittt et et et e et e e e et e et e et e et e et e st ean e eaa e et e et e enaaneanees 6

1.4 Example: RLC Circuit MOEL .......ivniiiiiieii e e e et e et e e e e e e e e e e eans 6
Generating a LaDVIEW EMI BIOCK ......ovuiiiniiiiiii e e e e eaas 7
Generating a LabVIEW Block for NI VeriStand or the LabVIEW SIT ........c.cooiiiiiiiiiiiiii e 7

2 Example: Exporting a Model as a LabVIEW EMI BIOCK ........couiiiniiiiiiiiiiie e 9
2.1 Preparing @ Model fOr EXPOTt ......oouiiiniiiiiiiiie ettt e e e e e e e e e b e e e e e e eens 9
Converting the Model to @ SUDSYSEEIM .. ...iuuiiiiiiieiie e e e e e e e e e e eeens 9
Defining Subsystem Inputs and OULPULS ........ouuiiiniiiiieiie et e e e e e e eaneeaneees 10

2.2 Defining and Assigning Subsystem Parameters ............cco.viueiiieiineiieiie e e e e e 14
2.3 Exporting Your Model Using the LabVIEW EMI Block Generation Template ..............cccoveiiiiiiiineiinnn.e. 15

3 Working with Your Block in NI VeriStand or LabVIEW SIT ..ot 17
3.1 Preparing Your MapleSim Model to Run in NI VeriStand ...........c..cooiiiiiiiiiiniiiniiiii e 17
Creating @ New Project FIle .......c.ouiiiiiiiii ettt e e e e et e e eens 17
Adding the MapleSim Model to the System Definition File ............ccoooiiiiiiiiiiiiiiiii e 17
RUNNING the PrOJECE ..ovniiiiiiii et e e e et e e et e e e e e e e e e et e et eaenaes 20
Adding a Dial to the WOTKSPACE .......ivuiieiiieie et e e e e e e e e e e e e e e e aaneees 21
Adding a Graph to the WOTKSPACE ........iiviiiiiiiiiei e e e e e e e eaeaas 23

3.2 Importing a MapleSim Model to the LabVIEW SIT Environment ...............oeevveiineiiniiineiieiineinneineannnns 25
Creating a LabDVIEW SIT INtEITACE .....uvvniiiiiiiiiiii e e e e e et e e e e e e eans 25
Connecting the MapleSim Model and the LabVIEW SIT User Interface .............coooeeiiiiiiiiiniiinininnnn. 26

4 Running a Simulation on a LabVIEW Real-Time Target Machine ................ccoooviiiiiiiiiiiiiiiniie e 28
4.1 Preparing the LabVIEW Real-Time Project ..........oiuuiiiiiiiiiiiiieie et 28
4.2 Moving the .dll File to the Target Real-Time Machine ..............ccoeoviiiiiiiniiiiiii e 31
£ [ PP P PSPPSR 34

il



Introduction

The MapleSim™ Connector for LabVIEW® and NI VeriStand™ Software provides all of the tools you need to prepare
and export your dynamic systems models to National Instruments™ (NI) LabVIEW as External Model Interface (EMI)
or Simulation Interface Toolkit (SIT) blocks, or as models for NI VeriStand™. You can create a model in MapleSim,
simplify it in Maple™ by using an extensive range of analytical tools, and then generate virtual instruments (VIs) that
you can incorporate into your LabVIEW or NI VeriStand toolchain.

You can also use these tools for exporting mathematical models that you have created from first principles in Maple
as Vls.

Furthermore, various options allow you to use the C code generation feature in Maple to create code libraries of your
MapleSim models for implementation in other applications.

Features include:

* Maple templates, which provide an intuitive user interface for optimizing your MapleSim model, and then generate
a dynamic-link library (.dll) file for LabVIEW or NI VeriStand.

* A range of examples illustrating how to prepare and export your models.

* Commands for developing VIs of mathematical models from first principles in the Maple environment and examples
to illustrate how to do it.

* Access to commands in the LabVIEWConnector package in Maple for developing dynamic-link library (.dll) files
for LabVIEW or NI VeriStand.

Scope of Model Support

MapleSim is a comprehensive modeling tool where it is possible to create models that could go beyond the scope of
this MapleSim Connector for LabVIEW and NI VeriStand Software release. In general, the MapleSim Connector for
LabVIEW and NI VeriStand Software supports systems of any complexity, including systems of DAEs of any index,
in any mix of domains, as long as they exhibit continuous behavior. Systems that contain any type of discontinuity,
including discrete transforms, switches, logic gates, relational and Boolean operations are not supported by the current
release of this product.

Apart from all of the engineering and signal components that are continuous, this product also supports lookup tables,
and custom components that do not use discontinuous operations such as piecewise functions.

System Requirements

For installation instructions and a complete list of system requirements, see the Install.html file on the product disc.

v



1 Getting Started
1.1 Getting Help

In Maple, enter 2LabVIEWConnector at a prompt in a worksheet.

1.2 Using the LabVIEW Component Block Generation Template

The MapleSim Connector provides LabVIEW Component Block Generation templates in the form of Maple work-
sheets for manipulating and exporting MapleSim subsystems. These templates contain pre-built embedded components
that allow you to generate EMI Components, SIT Components, or C code from a MapleSim subsystem, export the
subsystem as a LabVIEW block, and save the source code.

Using these templates, you can define inputs and outputs for the system, set the level of code optimization, chose the
format of the resulting EMI Component, and generate the source code, library code, block script, or LabVIEW block.
You can use any Maple commands to perform task analysis, assign model equations to a variable, group inputs and
outputs to a single vector and define additional input and output ports for variables.

Note: Code generation now handles all systems modeled in MapleSim, including hybrid systems with defined signal
input (Reallnput) and signal output (RealOutput) ports.

Block generation for EMI or SIT consists of the following steps:
» Subsystem preparation

* Subsystem selection

* Port and parameter management

* EMI or SIT component options

* Generate EMI or SIT component code

» View generated EMI or SIT component code

Subsystem Preparation

Convert your model or part of your model into a subsystem. This identifies the set of modeling components that you
want to export as a block component. Since LabVIEW only supports data signals, properties on acausal connectors
such as mechanical flanges and electrical pins, must be converted to signals using the appropriate ports.

To connect a subsystem to modeling components outside of its boundary, you add subsystem ports. A subsystem port
is an extension of a component port in your subsystem. The resulting signals can then be directed as inputs and outputs
for the LabVIEW Component Block Generation templates.

Note: For connectors you must use signal components since acausal connectors can not be converted to a signal.

By creating a subsystem you not only improve the visual layout of a system in model workspace and but also prepare
the model for export. The example in Chapter 2 shows you how to group all of the components into a subsystem.

Subsystem Selection

You can select which subsystems from your model you want to export to a LabVIEW block. After a subsystem is se-
lected, click Load Selected Subsystem. All defined input and output ports are loaded.
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Input Ports:
Input Variahles Part Grouping Name Change Row
1 |"Main.'Differentiator:; InputSignal’” (k) "InputSignal’
Qutput Ports:
Cukput Yariables Port Grouping Mame Change Row
1 |"Main. Tifferentiator:: YInput'™ (k) "WInput"
2 |"Main. Differentiator:: wOukput" (E) "WOukput”

Port and Parameter Management

Port and Parameter Management lets you customize, define and assign parameter values to specific ports. Subsystem
components to which you assign the parameter inherit a parameter value defined at the subsystem level. After the
subsystem is loaded you can group individual input and output variable elements into a vector array, and add additional
input and output ports for customized parameter values. Input ports can include variable derivatives, and output ports
can include subsystem state variables.

Note: If the parameters are not marked for export they will be numerically substituted.
The following selections specify the input ports, output ports, and states for generating LabVIEW blocks.

EMI or SIT Input Ports:

[] Add additional inputs for required input variable derivatives

Select Add additional inputs for required input variable derivatives to specify calculated derivative values instead
of numerical approximations.

EMI or SIT Output Ports:

[] Add an additional output port For subsystem state variables
Select Add an additional output port for subsystem state variables to add extra output ports for the state variables.

EMI Component Options
The EMI Component Options settings specify the advanced options for the code generation process.
Optimization Options

Set the level of code optimization to specify whether equations are left in their implicit form or converted to an ordinary
differential equation (ODE) system during the code generation process. This option specifies the degree of simplification
applied to the model equations during the code generation process and eliminates redundant variables and equations
in the system.

bl .

Lewel of code optimization {0=Mone, S=Full);

Select one of the following options:
None (0): no optimization is performed; the default equations will be used in the generated code.
Partial (1, 2): removes redundant equations from the system.

Full (3): performs index reduction to reduce the system to an ODE system or a differential algebraic equation (DAE)
system of index 1, and removes redundant equations.
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Constraint Handling Options

The Constraint Handling Options specifies whether the constraints are satisfied in a DAE system by using constraint
projection in the generated LabVIEW block. Use this option to improve the accuracy of a DAE system that has con-
straints. If the constraint is not satisfied, the system result may deviate from the actual solution and could lead to an
increase in error at an exponential rate.

Maxirnurn number of projection ikerations: |3

Error tolerance: |0, 1e—-4

Apply projection during event ikerations

Set the Maximum number of projection iterations to specify the maximum number of times that a projection is
permitted to iterate to obtain a more accurate solution.

Set the Error tolerance to specify the desirable error tolerance to achieve after the projection.
Select Apply projection during event iterations to interpolate iterations to obtain a more accurate solution.

Constraint projection is performed using the constraint projection routine in the External Model Interface as described
on The MathWorks™ web site to control the drift in the result of the DAE system.

Event Handling Options

The Event Handling Options specifies whether the events are satisfied in a DAE system by using event projection in
the generated LabVIEW block. Use this option to improve the accuracy of a DAE system with events. If the constraint
is not satisfied, the system result may deviate from the actual solution and could lead to an increase in error at an expo-
nential rate.

Mazximum number of event iterations: |10

width of ewent hysteresis band: [0, 12-9

[] &ptimize For use with fixed-step integrators

Set the Maximum number of event iterations to specify the maximum number of times that a projection is permitted
to iterate to obtain a more accurate solution.

Set the Width of event hysterias band to specify the desirable error tolerance to achieve after the projection.
Select Optimize for use with fixed-step integrators to optimize the event iterations as a function of hysterias bandwidth.

Event projection is performed using the event projection routine in the External Model Interface as described on The
MathWorks™ web site to control the drift in the result of the DAE system.

Generate EMI Component Code

Target directory: C:hUsershga Browse

LabWIEWw (32-bit) directory:  |C:% Program Files (xGé'Wational InstrumnetshLabWIEW 2010 Browwse

Wisual C++ directory: C:WProgram Files (x86%Microsoft Visual Studio 10.04WC Browse

Black Mame: MsiwmModel

Generate EMI Component ] [ Generate and Compile EMI Component ko LabYTEW
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Provide a block name, LabVIEW and Visual C++ directories and specify the location for the generated EMI file.
To generate EMI Component code without a LabVIEW connection, click Generate EMI Component.

To generate EMI Component code, click Generate and Compile EMI Component to LabVIEW.
SIT Component Options
These settings specify the advanced options for the code generation process.

Optimization Options

Set the level of code optimization to specify whether equations are left in their implicit form or converted to an ordinary
differential equation (ODE) system during the code generation process. This option specifies the degree of simplification
applied to the model equations during the code generation process and eliminates redundant variables and equations
in the system.

B .

Level of code optimization (0=Mone, 3=Full);

Select one of the following options:
None (0): no optimization is performed; the default equations will be used in the generated code.
Partial (1, 2): removes redundant equations from the system.

Full (3): performs index reduction to reduce the system to an ODE system or a differential algebraic equation (DAE)
system of index 1, and removes redundant equations.

Constraint Handling Options

The Constraint Handling Options specifies whether the constraints are satisfied in a DAE system by using constraint
projection in the generated LabVIEW block. Use this option to improve the accuracy of a DAE system that has con-
straints. If the constraint is not satisfied, the system result may deviate from the actual solution and could lead to an
increase in error at an exponential rate.

Maxirnurn number of projection ikerations: |3
Error tolerance: |0, 1le-4
Apply projection during event ikerations

Set the Maximum number of projection iterations to specify the maximum number of times that a projection is
permitted to iterate to obtain a more accurate solution.

Set the Error tolerance to specify the desirable error tolerance to achieve after the projection.

Select Apply projection during event iterations to interpolate iterations to obtain a more accurate solution. Constraint
projection is performed using the constraint projection routine in the External Model Interface as described on The
MathWorks™ web site to control the drift in the result of the DAE system.

Event Handling Options

The Event Handling Options specifies whether the events are satisfied in a DAE system by using event projection in
the generated LabVIEW block. Use this option to improve the accuracy of a DAE system with events. If the constraint
is not satisfied, the system result may deviate from the actual solution and could lead to an increase in error at an expo-
nential rate.
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Event Handling Options:

Mazximurn number of event ikerations: |10

‘Width of event bysteresis band: |0, 1e-9

Set the Maximum number of event iterations to specify the maximum number of times that a projection is permitted
to iterate to obtain a more accurate solution.

Set the Width of event hysterias band to specify the desirable error tolerance to achieve after the projection.

Event projection is performed using the event projection routine in the External Model Interface as described on The
MathWorks™ web site to control the drift in the result of the DAE system.

Baserate

The Baserate specifies the rate at which the model runs. Use this option to improve the accuracy of a DAE system
with events. If the constraint is not satisfied, the system result may deviate from the actual solution and could lead to
an increase in error at an exponential rate.

Baserate:

The rate at which the model runs: |0, 1e-2

Inputs
Specify the input type; internal, external or both.

Inputs:
Specify input bype: “internal’, "external” or both (default="internal™)

internal [ ] external

Generate SIT Component Code

Target directary: CihUsers ga
SIT directary: Ci:%Program Files (xS864National InstruwmnetshLabVIEW 2010
Visual C++ directory: |\ Program Filezs (®86%Microsoft Wisual Studio 10.04VC
Block Mame: MzimModsl

Generate SIT Companent ] [ Generate and Compile SIT Component bo Yeristand

Provide a block name, SIT and Visual C++ directories and specify the location for the generated SIT file.
To generate SIT Component code without a VeriStand connection, click Generate SIT Component.

To generate and compile SIT Component code into VeriStand, click Generate and Compile SIT Component to
VeriStand.

View EMI or SIT Component Code

After you generate the EMI Component code and create the block, a LabView command window opens and the block
with any of the following specified parameters is generated in LabVIEW:

¢ Header File
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¢ CCode

1.3 Using the LabVIEW Block Generation Templates

The MapleSim Connector for LabVIEW and NI VeriStand Software provides an NI LabVIEW EMI Block Generation
template and an NI VeriStand and LabVIEW SIT Component Model Generation template in the form of Maple
worksheets for manipulating and exporting MapleSim subsystems. These templates contain pre-built embedded com-
ponents that allow you to generate LabVIEW blocks from a MapleSim subsystem, export the subsystem as a LabVIEW
block and Microsoft® Visual Studio® project, and save the source code.

Using either of these templates, you can define inputs and outputs for the system, generate the source code and library
code.

Example models are available in the NI Connector Examples palette in MapleSim.
Viewing Examples
To view an example:

1. In the Libraries tab on the left side of the MapleSim window, expand the NI Connector Examples palette, and
click the entry for the model that you want to view.

W NI Connectar Examples :-

RLC Parallel Cirzuit %
Non-lingar Spring Damper
Double Wishbone Suspension

Stewart Platform

Some models include additional documents, such as templates that display model equations or define custom components.

2. In the Project tab, expand the Attachments palette and then expand Documents. You can open any of these documents
by right-clicking its entry in the list and clicking View.

After you add a template to a model, it will be available from this list.

1.4 Example: RLC Circuit Model

In this example, you will generate a LabVIEW EMI or SIT block, or a block for NI VeriStand using an RLC circuit
model that was created in MapleSim.

To generate a LabVIEW block:

1. From the NI Connector Examples palette, open the RLC Parallel Circuit example.

2. Click the templates button ( & ) in the main toolbar.

3. From the list, select NI LabVIEW EMI Component Block Generation to generate a LabVIEW EMI block or NI
VeriStand and LabVIEW SIT Component Model Generation to generate a block for the LabVIEW Simulation
Interface Toolkit or NI VeriStand.

4. In the Attachment ficld, enter RLC Circuit as the worksheet name.

5. Click Create Attachment. Your MapleSim model is opened in Maple, in the template that you selected.
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6. Browse to the RLC Parallel Circuit 1 subsystem by selecting the subsystem name from the drop-down menu in
the toolbar above the model diagram. This menu displays all of the subsystems and components in your MapleSim
model.

7. In the Model Input from MapleSim section of the template, click Load Selected Subsystem. All of the template
fields are populated with information specific to the subsystem displayed in the model diagram. You can now specify
which subsystem parameters will be kept as configurable parameters in the generated block.

8. In the Setting Parameters section, select the Main.RLC Parallel Circuitl::R parameter entry in the Parameter
Name list.

Note: The Keep as Block Parameter box is checked by default. Also by default, all parameters in the model are kept
as configurable parameters.

9. To change the default value of the resistance parameter, select Main.RLC Parallel Circuit1::R from the Parameter
Name list, enter 5 in the Value field, and click the Update button.

10. In the Advanced Code Generation Settings section, set the Code Optimization option to Full. This option specifies
the degree of simplification applied to the model equations during the code generation process. This option eliminates
redundant variables and equations in the system.

If you plan to generate a LabVIEW EMI block, follow the steps in the Generating a LabVIEW EMI Block section
below. If you plan to generate a block for NI VeriStand or the LabVIEW Simulation Interface Toolkit, follow the steps
in the Generating a LabVIEW Block for NI VeriStand or SIT section below.

Generating a LabVIEW EMI Block
1. In the Generate the Shared Library Code section of the template, specify the LabVIEW and Visual C++ directories.

2. Click Generate to LabVIEW to generate the Visual Studio project and dynamic-link library (.dll) file for the EMI
block.

3. In LabVIEW, open a new VI and open the block diagram window by selecting Windows>Show Block Diagram.

4. Right-click the canvas and select Control Design & Simulation>Simulations>Control and Simulation Loop.
Click the canvas and draw a simulation loop box.

5. Right-click the simulation loop box and select Control Design & Simulation>Simulations>Ultilities>External
Model. Click a point in the box to position the model.

6. In the Select an External Model Library window, browse to the Release subfolder located in the default directory
that you specified in the LabVIEW EMI Block Generation template and open the .dll file that you generated.

7. Click OK.
Note: Generating a block may require a few minutes.

You can now use the RLC circuit block in a LabVIEW EMI diagram. To view a complete example that describes how
to prepare and export a slider-crank model as a LabVIEW EMI block, see Example.: Exporting a Model as a LabVIEW
EMI Block (page 9).

Generating a LabVIEW Block for NI VeriStand or the LabVIEW SIT

1. In the Generate the Shared Library Code section of the template, specify the LabVIEW SIT and Visual C++ dir-
ectories.

2. In the SIT version field, specify a value of 2009 or 2010.

3. Click the Generate DIl button
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Note: Generating a block may require a few minutes.

For more information about preparing your block for either the NI VeriStand or LabVIEW SIT environment, see
Working with Your Block in NI VeriStand or LabVIEW SIT (page 17).



2 Example: Exporting a Model as a LabVIEW EMI Block
2.1 Preparing a Model for Export

In this example, you will perform the steps required to prepare a slider-crank mechanism model and export it as a
LabVIEW EMI block.

1. Convert the slider-crank mechanism model to a subsystem.

2. Define subsystem inputs and outputs.

3. Define and assign subsystem parameters.

4. Export the model using the LabVIEW EMI Block Generation template.

5. Implement the EMI block in LabVIEW.

To open the slider-crank mechanism example:

1. In MapleSim, expand the Examples palette and then expand the Tutorial submenu.

2. Open the Slider Crank example.

W Examples oE

P Electric Circuits
P Getting Started
P Hydraulic
P Magnetics
P Mechanical
P Multibody
P Multidomain
P Signal Processing
P Thermal
W Tuktarial
Cable Tension
DT Motorwith Pl Contral
MNaon-linear Spring Damper
RLE Circuit
Simple DC Motor

Slider Crank

P isualization

Converting the Model to a Subsystem

By converting your entire model or part of your model into a subsystem, you identify which parts of the model that
you want to export. In this example, you will group all of the components into a subsystem.
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1. Using the selection tool ( & ) located above the model workspace, draw a box around all of the components in the
model.

Probe2

i phi
}L—{)}—'_' Q?*—'_' .?‘}
E -2 Crank 2" ConnectingRod

Probe1 °

-

2. From the Edit menu, select Create Subsystem.
3. In the Create Subsystem dialog box, enter SliderCrank as the subsystem name.

4. Click OK. A SliderCrank subsystem block appears in the model workspace.

S mrl}am'cl

Defining Subsystem Inputs and Outputs

MapleSim uses a topological representation to connect interrelated components without having to consider how signals
flow between them, whereas traditional signal-flow modeling tools require explicitly defined system inputs and outputs.
Since LabVIEW only supports data signals, properties on acausal ports, such as mechanical flanges and electrical pins,
must be converted to signals using the appropriate components. The resulting signals are directed as inputs and outputs
for the subsystem in MapleSim and for the EMI block.

Note: Currently, code generation is limited to subsystems with defined signal input (Rea/lnpuf) and signal output
(RealOutput) ports.

In this example, you will convert the displacements of the slider and the joint between the crank and connecting rod
to output signals. The input signal needs to be converted to a torque that is applied to the revolute joint that represents
the crank shaft.

1. Double-click the subsystem block to view its contents. The broken line surrounding the components indicates the
subsystem boundary, which can be resized by clicking and dragging its sizing handles.

2. Delete the probes that are attached to the model.

3. In the Libraries tab on the left side of the MapleSim window, expand the Multibody palette and then expand the
Sensors submenu.
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4. Drag the Absolute Translation component to the model workspace and place it below the Prismatic Joint component.

- o

&
A
5. Right-click (Control-click for Macintosh®) the Absolute Translation component and select Rotate Counterclock-

wise.

6. From the Signal Blocks — Routing — Demultiplexers menu, drag a 3-port Demultiplexer component to the
model workspace and place it to the right of the Absolute Translation component.

L ] o

— e

&

7. To connect the Absolute Translation component to the model, click the frame b connector. The frame is highlighted
in green when you hover your pointer over it.

—ein

& <

8. Draw a vertical line and click the connection line directly above the component. The sensor is connected to the rest
of the diagram.

L ] o

—aiE
|
& g

9. In the same way, connect the r output port ( TMOutputP ) of the Absolute Translation component to the navy

blue input port of the demultiplexer. This is the displacement signal from the sensor in X, y, and z coordinates. Since
the slider only moves along the x axis, the first coordinate must be an output signal.
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10. Hover your pointer over the first demultiplexer port and click your mouse button once.

[,
o RN

11. Drag your pointer to the subsystem boundary.

L,
e +

12. Click the boundary once. A real output port is added to your subsystem.

| |

13. Add another Absolute Translation component above the Connecting Rod subsystem.

14. Right-click (Control-click for Macintosh) the Absolute Translation component and select Flip Vertical. Right-
click the Absolute Translation component again and select Rotate Clockwise.

15. Add a 3-port Demultiplexer component to the right of the sensor and connect the components as shown below.

Q) ot
. e
CopnectingR od

Since the crank is moving in the x, y plane, you only need to output the first two signals.

You will now add a real input port to your subsystem to control the torque on the crank shaft.

16. From the 1-D Mechanical — Rotational — Torque Drivers menu, add a Torque component to the model
workspace and place it above the Fixed Frame component.

17. Connect the white flange of the Torque component to the white flange of the leftmost Revolute Joint.
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",j\

o

18. Click the input port of the Torque component and drag your pointer to the subsystem boundary.

19. Click the boundary once. A real input port is added to your subsystem.

A,
> s

o

The complete subsystem appears below.

8 'r:-’,%?t

(R [ o
s " o e -\_’ 5
X I N
..
o
s . .
Kr Conk Ko Connae ling Rod

e <
.-_'41_ ] Sl

20. Click Main above the model workspace to browse to the top level of the model.
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21. From the Signal Blocks — Sources — Real menu, drag a Constant source into the model workspace and connect
its output port to the input port of the SliderCrank subsystem as shown below.

ROy

SlickerCran) |'r.]

22. Click the probe button ( #2 ) above the model workspace.
23. Click the top output port of the SliderCrank subsystem.
24. In the model workspace, click the probe once to position it.

25. In the same way, add probes to the other SliderCrank output ports as shown below.

Probe1

. walue
I3

Probe2

value

= n “---.__ - Probe3
SliderCrank, ‘(:)

value

2.2 Defining and Assigning Subsystem Parameters

You can define custom parameters that can be used in expressions in your model to edit values more easily. To do so,
you define a parameter with a numeric value in the parameter editor. You can then assign that parameter as a variable
to the parameters of other components; those individual components will then inherit the numeric value of the parameter
defined in the parameter editor. By using this approach, you only need to change the value in the parameter editor to
change the parameter values for multiple components.

1. While in the detailed view of the SliderCrank subsystem, click the parameter editor button ([-#) above the model
workspace. The parameter editor appears.

2. In the New Parameter field, define a parameter called CrankL and press Enter.

3. Specify a default value of 1 and enter Length of the crank as the description.

4. In the second row of the table, define a parameter called ConRodL and press Enter.

5. Specify a default value of 2 and enter Length of the connecting rod as the description.

SliderCrank subsystem default settings

Mame Type Default Value Default Units Description

4

Cranid Feal Length of the crank

4
[ERR—

ConRodl Feal Length of the connecting rod
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6. Click 2| to switch to the diagram view. The parameters are defined in the Parameters pane.

Inspector | Settings | Plots
Name | SliderCraniy

Type Standalone Subsystem

¥ Parameters
CraniL 1

ConRodl |2

7. In the model workspace, select the Crank subsystem.

8. In the Parameters pane, change the length value (L) to CrankL.

Inspector | Settings | Plats

MName Crank
Type Link

¥ Parameters
L Crankl

The Crank subsystem now inherits the numeric value of CrankL that you defined.
9. Select the ConnectingRod subsystem and change its length value to ConRodL.

10. Click the Main button above the model workspace to navigate to the top level of the model.

RO2y

Sl J'E‘DrCmnl'f.1

You will include these parameter values in the model that you export. You are now ready to convert your model to an
EMI block.

2.3 Exporting Your Model Using the LabVIEW EMI Block Generation
Template

After preparing the model, you can use the LabVIEW EMI Block Generation template to set export options and convert
the model to a LabVIEW EMI block.

1. Click the templates button ( @ ) in the main toolbar.

2. From the list, select NI LabVIEW EMI Component Block Generation.

3. In the Attachment field, enter Slider Crank EMI as the worksheet name and click Create Attachment. The slider-
crank subsystem is opened in the LabVIEW EMI Block Generation Template in Maple.

4. Use the navigation controls above the model diagram to select the SliderCrank subsystem and click Retrieve System.
All of the template fields are populated with information specific to the subsystem.

5. Click Generate to LabVIEW to generate the block.

6. Set the LabVIEW and Visual C++ directory paths.
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7. At the bottom of the template, click Generate to LabVIEW to generate the Visual Studio project and dynamic-link
library (.dll) file for the EMI block.

8. In LabVIEW, open a new VI and open the block diagram window by selecting Windows>Show Block Diagram.

9. Right-click the drawing canvas and select Control Design & Simulation>Simulations>Control and Simulation
Loop. Click the canvas and draw a simulation loop box.

10. Right-click the simulation loop box and select Control Design &Simulation>Simulations>Utilities>External
Model. Click the simulation loop box to position the model.

11. In the Select an External Model Library window, browse to the Release subfolder located in the default directory
that you specified in the LabVIEW EMI Block Generation template and open the .dll file that you generated.

12. Click OK.

13. Connect the output of the block to a scope and the input to a sine wave.



3 Working with Your Block in NI VeriStand or LabVIEW SIT

Using the RLC circuit block that you generated in Example: RLC Circuit Model (page 6), this chapter describes how
to work with your block in NI VeriStand or the LabVIEW SIT environment.

* Preparing Your MapleSim Model to Run in NI VeriStand (page 17)
» Importing a MapleSim Model to the LabVIEW SIT Environment (page 25)

3.1 Preparing Your MapleSim Model to Run in NI VeriStand

Creating a New Project File

1. Open NI VeriStand.

2. From the File menu, select New Project.

3. In the New Project Name field, enter RLC Circuit.

4. Click OK.

5 In the Create New Project window, select the System Definition tab.

6. Select the Create a new NI VeriStand System Definition file radio button.

® Create New Project @

Project | SystemDefintion | Properties

@ Create a new NI VeriStand System Definition File
Use project name

(O Use an existing NI VeriStand System Definition File

[ OK ] [ Cancel ] [ Help ]

7. Click OK. A new project file is created, along with a system definition file.

Adding the MapleSim Model to the System Definition File
1. From Start >All Programs > National Instruments > NI VeriStand 2010, select System Explorer.
2. In the System Explorer window select File, then Open,

3. Navigate to the project you created in the previous section, Preparing Your MapleSim Model to Run in NI Veri-
Stand (page 17).

17
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4. Open RLC Circuit.nivssdf.

Select a system def

My Recent
Documents

©,

Desktop

)

My Documents

59

My Computer

My Network

tion to open

Look: | €2 IR v 01 @
(DLogs
[C)XNET Raw Frame Files
RLC Circuit.nivssdf
File name: |RLC Crout nivssdf v [ ok |
Files of type: \System Definttions (" nivssdf) v/ | Cancel :

5. In the left pane, expand Controller, click Simulation Models then click Models.

Fie Edt Tools Hep
mSH | %
B Yc o

+gm Hardware

A Vocels
User Channels

e Stimulus:
Alarms
Procedures

b a3 Aliases

== System Mappings
Data Sharing Network
L3 System Initialization

() Custom Devices
=+ fiff Simulation Models
@ Execution Order

|-/ Calalated Channeis

XNET Databases
#+3 7 System Channels

>

System Explorer Window

Use this window to create and/or medify a system definition file. You cenfigure a system definition file by adding,
removing, and modifying options in the configuration tree, located on the left of the System Explorer window.
Using the System Explorer window, you can define various components of the system, including alarms,
calculated channels, hardware 1/0, system mappings, procedures, simulation models, system channels, user
channels, and some VeriStand Engine execution settings.

For more information about using the System Explorer window, refer to the Configuring and Running & Project
book of the NI VeriStand Help, available by selecting Help»Search the NI VeriStand Help.

Refer to the Components of a Project book for detailed descriptions of system definition files and the VeriStand

Enaine.

System Definition File Settings

Name
RLC Circuit

Creator Creation date

10:05:59 AM 17/03/2011

Desaription
F
v

Minor Fix Buid
L & o 3] [o sl [o g
 feion |
Revision history
I A

<
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6. Click the Add a Simulation Model button located above the right pane. The Add Simulation Model window is
displayed.

. Add Simulation Model 3

General Settings | Parameters and Signals | Inports and Outports

Name
RLCParallelCircuit1

Path

C:\Documents and Settings\maplesoft\Desktop\akorobkine \RLC\Release, @
RLCParallelCircuit1.dll

Simulation mode! info
Model rate: 1000 Hz A

Path: C:\Documents and Settings\maplesoft\Desktop\akorobkine\RLC \Release\
RLCParallelCircuit1.dll

Modification date/time: 9:14:31.000 AM 17/03/2011

File size (Byte): 73728

File version:

Product name:

Internal name:

Company name:

Legal copyright:

File description:

[ oK ] [ Cancel ] [ Help ]

7. In the General tab, click the browse button ([i&r]) and open the .dll that you created in Example: RLC Circuit
Model (page 6).

8. In the Parameters and Signals tab, select Import all Signals.

9. In the Inports and Outports tab, select Segment into scalar channels.
10. Click OK.

11. Save your changes.
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Running the Project

1. In the NI VeriStand - Getting Started window, click the Run Project button.

® Getting Started Window

| Mew NI VeriStand Project ‘ News.
' FPGA Personality Tools
Most Recent Projects
. 14 NIVeriStand Helps Company Save $200k
& RLC Circuit o
1 Custom Workspace Objects
I’ RLC t
o ' using CAN, LIN, and FlexRay
[ EngineModel W creating FPGA 1/0 for NI VeriStand
[ Snewave Delay 0 Building Distributed Systems
€ Browse = Read All Blogs (8 unread)
Active Project Help
RLC Circuit.nivsproj A @ What's New in NI VeriStand 2010
System Definition File: C:\Documents and 9 Getting Started with NI VeriStand 2010
Settings\All Users\Documents\National Instruments\
NI VeriStand 2010\Projects\RLC Circuit RLC 9 Configuring and Running a Project
Circuit.nivssdf
v 9D NI VeriStand Video Tutorials
4, Configure Project &, Run Project ? 1w venstand acd-ons

2. In the blank workspace that you opened, from the Screen menu, select Edit Mode.
3. Click the Workspace Controller tab on the left side of the workspace.
4. In the Workspace Controls menu, expand Model.

M Workspace Controls L

# - Boolean Control
% Boolean Indicator

& Decaration
i+ Graph
= Model
[Model Control
- Model Calibration Control
i+ Numeric Control

+
* Numeric Indicator
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5. From the Workspace Controls pane, drag the Model Control label into the workspace to add a model control
component.

M Workspace - RLC Circuit Q@El
File Tools Sceen View Window Help

|E||E| [screen v 1 oof 1

2

b

5 +

[¥] Controller /RLCParallelCircuit 1

o

| S ][ ——

2

Model running...

6. From the Item Properties window, select RLC.

¥ Item Properties

Model: Controller/RLCParallelCircuit 1 v
I OK ] [ Cancel
7. Click OK.

Adding a Dial to the Workspace

1. Click the Workspace Controller tab.
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2. In the Workspace Controls menu, expand Numeric Control.

M Workspace Controls

+ - Auto
#  Boolean Control
#  Boolean Indicator
# - Decoration
@ Graph
= Model

Model Contral

Model Calibration Control
= Nureric Control

Dial

Mediurm
@& Numeric Indicator

i+

3. Drag the Dial component into the workspace.

L Workspace - RLC_Tutorial
File Tools GScreen View Window Help

Displayed Screen: 1 of 1
o Emiplty Screen

+

GOl

Workspace Controls mﬂ

a 0 g
LY ')
30,_ 70
20- -80
10~ ~gp
- A
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The Item Properties window is displayed.

A Item Properties

General | Format & Precision | Limits & Warnings

Channel:

ControllerjSimulation Models/ModelsRLC/Inports/ 5
Main__RLC_Parallel_Circuit]_ Reallnput1_t_
Control Label:

Main__RLC_Parallel_Circuitl__Reallnputl_t_

Default Units: Mew Uniks:

[¥]use Default Units?
Scale Factor: Offsek:
1 ool 0 =

Lok J [ come |

4. In the Item Properties window, click the channel button ().
5. Expand Controller>Simulation Models>Models>RLCParallelCircuitl>Inports.

6. Select Main_RLC_Parallel_Circuitl _Reallnputl_t_

= @RLC Circuit
= $yTargets
= wController
= Afsimulation Models
= Avodels
(= ©-RLCParallelCircuit1
# Execution
= OInports
# +-Stimulus
# ¢ ?System Channels

7. Click OK.
8. Click OK.

Adding a Graph to the Workspace

1. Click the Workspace Controller tab.
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2. In the Workspace Controls menu, expand Graph and drag the Simple label into the workspace.

M Workspace Controls

+ Auto
+ Boolean Contral
+ Boolean Indicator
+ Decoration
Graph
FFT
Simple
= Model
Model Control
# - Model Calibration Control
= Numeric Control
Dial
Medium
+ Mumeric Indicator

3. In the Graph Channel Selection window, in the left pane, expand Controller > Simulation Models > Models >
RLCParallelCircuitl > Outports.

¥ Graph Channel Selection |z|

General | Format & Precision

Graph Title: ) History Length: _Updahe Rate:

Graph 10.0 % | |5Hz v

Allow Resize?
@ [ Legend Text Variable A

Main__RLC_Parallel_Circustl_ RO1_  Targets/Controller tion Models, els, aral
| = ] RLC_Parallel_Ci RO1 T JCe ller /Simula dels/Models/RLCParall
= @RLC Circuit |
= YyTargets
= pController
= gPSimulation Models
= @M odels

= o-RLCParallelCircuit1

& )Execution
% Clnports é
= £30utports
1 Main__RLC_Parallel_
® EESignals
o +~-Stimulus

# 3 2System Channels

@l

L 2 v

Delete OK Cancel
) |

4. Select Main_RLC_Parallel_Circuitl__RO1_t_

5. Click the right-pointing arrow () to include the outport quantity in the graph.
6. Click OK.

7. From the Screen menu, clear the Edit Mode option.
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8. In the workspace, rotate the dial to change the input behavior. The results are displayed in the graph.

. Workspace - RLC Q@@
fle Toos Scoeen Ve e
< 3] o= g . o
+
Controller/RLCParallelCirauit1 Graph
B0 522 ) ain_RLC_Parale_Circut1_Ro1_t_ [/ e Legend
Autoscale X
2 P e
\ ‘
N n Autoscale Y
B ——— -
20- -80 00:08:31 00:08:34 00:08:3%  00:08:38 00:08:40  00:08:41 @
-
10- ~o0 BEaw
. . - Data Lost
0 100

3.2 Importing a MapleSim Model to the LabVIEW SIT Environment

Creating a LabVIEW SIT Interface

1. Open a new VI file.

2. In the Front Panel, right-click to open the Numeric Controls panel.

| Q,,,Search] e I -f I

¥ Express

L Murneric Contrals

n5 WM o0 5 10 -

'0" e | .
o L &
b User Contrnl

Select a Conkral,..

w

3. Select Numeric Controls and then select Dial.
4. Drag the Dial component into the Front Panel
5. Right-click the Front Panel

6. Select Graph Indicators

7. Select Chart.
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8. Drag the chart component into the Front Panel

13 Untitled 1 Front Panel *

8]

5-

Fle Edt View Project Operste Took Window Help =
[ ][] @[ m] [ 130t Appication Fort |~ (3|70~ | -] [€5-] 48
Waveform Chart Plot 0 m J A
Dial 10-
FIENF
[,

Tiene

Connecting the MapleSim Model and the LabVIEW SIT User Interface

1. From the Tools menu, select SIT Connection Manager

2. In the SIT Connection Manager window, select Driver VI on Localhost.

3. In the Current Model DLL section, browse to and select the .dll that you created.

13 §IT Connection Manager - Untitied 1

Cabagory
Madel and Host Execution Host
Mappings
Cata Logging ) Samulath onment: ot
Fie Playback o i
Hardweans [j0 () Readh Timwt: Targat
i Port
() Eriver ¥1 on Localhwost &0L1 =

Curranit Moded DLL
Ci¥Documents and Settings¥wsong¥Desktop¥F slease¥RLC, dil

Prajeck Dinackory
C¥Documants and Settings¥wsong¥DesktopWR.tiexse

[ =

=

Help

4. In the left pane of the SIT Connection Manager, sclect Mappings.

5. In the Current Mappings table, double-click the first row which corresponds to the dial that you inserted.

6. Expand rlcparallelcircuit]1>Input_param
7. Select Main_RLC_Parallel_Circuitl __Reallnputl_t_
8. Click OK.

9. Below Current Mappings, double-click Waveform Chart.
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10. Expand rlcparallelcircuit1>Output>Main_RLC_Parallel_Circuitl _RO1_t_
11. Select Port 1 - Main_ RLC_Parallel_Circuitl _RO1_t

12. Click OK.

13. Click OK. The SIT Connection Manager will now build the model.

14. Click the run button ([E]) to run the simulation. When the simulation is complete, you can rotate the knob to change
the output.

(8 Untitied 1 ok
File Edt Yisw Project Operabe Tools Mindow Help
Madel Controls

(>] [w[=]s]3]0)

[Runring

~

Waveform Chabiain_PLC_Paralel Circuit1_Ro1 t_1 NG




4 Running a Simulation on a LabVIEW Real-Time Target
Machine

You can run a simulation on a LabVIEW real-time target machine by using any .dll file that you generate using the
MapleSim Connector for LabVIEW and NI VeriStand Software. In this chapter, the steps for running a real-time sim-
ulation are demonstrated using the slider-crank .dll file that was generated in Example: Exporting a Model as a LabVIEW
EMI Block (page 9) in Chapter 2 of this guide. These steps can also be applied to any .dll file for which you want to
run a real-time simulation.

4.1 Preparing the LabVIEW Real-Time Project
1. From the LabVIEW Getting Started window, click Real-Time Project.

2. Keep the project type as Continuous communication architecture, change the project name to RTSliderCrank,
and click Next.

P Create new LabVIEW Real-Time project

Select project type, name, and folder

Project type m

Continuous communication architecture W

[#] Apphcation inchudes deterministic components L]

Chiecking this box wall restrick options on the next page to
ensure the project can run a deterministic loop epnmmaname

Project namme
RTShderCran

Project folder

CADocuments and Settingslwwong| by Documents|
LabVIEW DatalRTShderCrank

28
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3. Keep all of the default architecture options values and click Next.

-

P Create new LabVIEW Real-Time project

Customize architecture oplions
Target Configuration
() One loop

Target VI runs one timed loop
(O Twa loops

Target VI runs two timed loops at different priorities to
separate deterministic and non-deterministic

Inchude Fils 170
Host Configuration
[ inchsds user interface
) Host W1
Use a VI on the host to communicate with target
Remote Panel

Use a web browser bo communicate with t

arget

-

4. Click Browse... From the drop-down menu, browse to locate the real-time target platform. Click Next.

P Create new LabVIEW Real-Time project

Browse targets

Add a networked target, such as PX1, Compact FieldPoint,

FieldPoint, CompactR10, Single-Board RIO, Compact Vision
System

Selected target

| <Back || memt> | | Frh

J|_concel ][ e |

5. Click Finish to create the model. The model is displayed.
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6. From the Project Explorer, right-click the entry of the target platform and select Add >File...

® Project Explorer - RTSliderCrank. Ivproj E”Elgl
File Edt Wiew Project Operate Tooks Window Help
[HSHE | XD O XYgR| R o
Rems | Fias
= ) Project: RTSkderCrank vproj
= W My Computer
|- %" Dependencies
L' Buld Speciications
SR N vrrPI02 (10. 1 T »
[~ target - sing
i support - ac Export L4
4 Dependency  1mport 4
= Buid Specii g »
Folder (Snapshat)...
Folder (Auto-populating).... ‘
Utities p perak..
Deploy
Deplory A1
Arrange by 3
Expand All
Collapze Al
Resmive From Project
Renams... F2
Properties

7. Browse to the Release subfolder located in the default directory that you specified in the LabVIEW EMI Block
Generation template and open the .dll file that you generated. Click OK.

8. Navigate to the block diagram of the VI. Double-click the Simulation Parameters window to the left of the simu-
lation loop. The Configuration Simulation Parameters window is displayed.

=

B testpage_InLoop.vi Block Diagram on TestCase.lvprojiwmPXI102 * EI@|E]
File Edt View Project Operate Tools Window Help &
[>]@] &[] [@][25] loafmPl o [ 130t Avpication Fork - ]85~ ][-5a~] [€5

~
simulation time
&)l
RE Main.CrankL
rarp[1E-10 | )
IZ 1230
amplitude = |
Main. ConRodL
]
N
TestCase. vproj/wmPXI0DZ £ >




31

* Running a Simulation on a LabVIEW Real-Time Target Machine

9. Click the Time Parameters tab and select Synchronize loop to time source. Click OK.

B Configure Simulation Parameters

Simulstion Parameters | Timing Parameters

Enable Synchronized Timing
Synchronize Loop bo Timing Source

hize the simulation kop to & timng source

Source bype

1 kHz Clock -
1 MHz Clock

1 kHz <reset at struchure stark>

1 MHz <reset at structure start>

SOUrce namme
1kHz
Loop Timing Attributes
Calculated Period
1 [#] Auto Period
Offzet | Phase Priority
0 - 100 F
Deadiine Tineaut (ms)

=1 = A -

Processor Assignment
Mode

Hujtoenatic b

10. Save the file.

4.2 Moving the .dll File to the Target Real-Time Machine

1. From the start menu, select Measurement and Automation Explorer.

2. In the Measurement and Automation Explorer window, expand Remote Systems.

3. Right-click the entry for your target machine
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4. Select File Transfer

= ﬂ Devices and Interfaces
w 4 Scales
@ (5] Seftwars
% [ 1 Crivers
= £ Remate Systems
== wamlabrviewOl
& = wmPRI01

= b [T

(1) meboot
9 Lod
Wiew Error Log

i
Bl CresteRepert...

S Impeet...
W Export...

4p Fommat Disk
| Delete

5. Browse to the directory that contains the .dll file you created.
6. Select the .dll file.

B File Transfer

7. Click To Remote to move the .dll file from your local machine to the target machine in the ni-rt/system directory

8. Click Close
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9. Run the simulation by clicking the run button in the front panel of the VI.

P testpage_InLoop.vi Fromt Panel on TestCase. lvprojfwmP X2
Bie Edt Yew Bromct Cperate Dook pndow Mep EJ|

S [ @] @[] [ 136 epicaton Fore_— + |3~ ] ][] [€5-] - =

Vet ade, b w0l (2 ¥
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